
Hi Bin,
On 1 July 2015 at 18:12, Bin Meng bmeng.cn@gmail.com wrote:
Hi Simon,
On Wed, Jul 1, 2015 at 10:59 PM, Simon Glass sjg@chromium.org wrote:
Hi Bin,
On 1 July 2015 at 02:28, Bin Meng bmeng.cn@gmail.com wrote:
Move X86_OPTION_ROM_FILE & X86_OPTION_ROM_ADDR to arch/x86/Kconfig and rename them to VGA_BIOS_FILE & VGA_BIOS_ADDR which depend on HAVE_VGA_BIOS. The new names are consistent with other x86 binary blob options like HAVE_FSP/FSP_FILE/FSP_ADDR.
Signed-off-by: Bin Meng bmeng.cn@gmail.com
Makefile | 4 ++-- arch/x86/Kconfig | 22 ++++++++++++++++++++++ configs/chromebook_link_defconfig | 1 + configs/chromebox_panther_defconfig | 1 + configs/minnowmax_defconfig | 1 + doc/README.x86 | 2 +- drivers/pci/pci_rom.c | 6 +++--- include/configs/minnowmax.h | 3 --- include/configs/x86-chromebook.h | 3 --- 9 files changed, 31 insertions(+), 12 deletions(-)
It's good to move these to Kconfig. But why should we rename it from option ROM to VGA ROM? Is it not possible that we might want to run some other ROM?
I think the only ROM we want to support in U-Boot is VGA, so I changed it to specifically mention VGA. There are other two typical type of ROMs, PXE ROM for network boot and AHCI ROM for disk read/write which U-Boot has native drivers to do that. Besides, I suspect current bios interrupts codes could handle PXE ROM or AHCI ROM call correctly as they were written for VBE calls.
OK, sounds reasonable. We could generalise later if such supported becomes needed. But it sounds unlikely from what you are saying.
Acked-by: Simon Glass sjg@chromium.org
Regards, Simon