
Dear Wolfgang,
Since the cpu/ directory gets clobbered with peripheral driver code I started cleaning up cpu/arm920t.
Thanks for the effort, but I disagree with some parts of the patch.
- rename cpu/arm920t/usb_ohci.c to drivers/s3c24x0_usb_ohci.c
I disagree with this. drivers/ is for device drivers that are _common_ among architectures. It makes absolutely no sense to mode processor specific code like the s3c24x0 USB drivers to this directory.
Accepted. I found some processor specific driver code in drivers/ (like s3c24x0_i2c.c s3c4510b_eth.c s3c4510b_eth.h s3c4510b_uart.c s3c4510b_uart.h) so I thought it becomes "common practice" to put peripheral driver code for uart or ethernet (although it might be processor specific) into drivers/.
- remove cpu/arm920t/usb_ohci.h (duplicate code)
Duplicate to what?
Duplicate to cpu/mpc5xxx/usb_ohci.h.
- rename cpu/mpc5xxx/usb_ohci.h to drivers/usb_ohci.h so everybody can use it (maybe we can merge cpu/arm920t/usb_ohci.c and cpu/mpc5xxx/usb_ohci.c someday)
Be careful. Do you really think this is a good idea? The 52xx USB code suffers from the endinaess problem of the 52xx. I'm not sure if this is a good base for common code.
The only difference I found is
+#if defined(CONFIG_MPC5200) + __u16 pad1; /* set to 0 on each frame_no change */ + __u16 frame_no; /* current frame number */ +#else __u16 frame_no; /* current frame number */ __u16 pad1; /* set to 0 on each frame_no change */ +#endif
Thanks,