
On 09/18/2012 07:25 PM, Rob Herring wrote:
On 09/18/2012 08:21 PM, Rob Herring wrote:
On 09/18/2012 05:37 PM, Stephen Warren wrote:
From: Stephen Warren swarren@nvidia.com
This patch introduces function get_device(). This looks up a block_dev_desc_t from an interface name (e.g. mmc) and device number (e.g. 0). This function is essentially the non-partition-specific prefix of get_device_and_partition().
Then shouldn't get_device_and_partition just call get_device. Perhaps create get_partition() and then get_device_and_partition is just a wrapper.
I should read all the way through the series before replying...
Anyway, I would squash it all unless you want to have restructuring with current functionality and then enhancements.
OK, I'm happy to squash everything together, and repost a series with both your and my patches; I separated it out to hopefully make working out what changes I made a little easier.
I did wonder about creating separate get_device, get_partition, and get_device_or_partition functions, the latter probably using a common implementation. I guess if I squash my changes into your original patches, then creating those 3 separate functions would end up being less churn. So, unless there are objections, I'll do that.