
25 Jul
2014
25 Jul
'14
8:45 p.m.
Hi,
On 25-07-14 20:19, Stefan Roese wrote:
On 25.07.2014 19:07, Gerald Kerma wrote:
This patch add Marvell kirkwood MVSDIO/MMC driver and enable it for Sheevaplugs and OpenRD boards.
Signed-off-by: Gerald Kerma drEagle@doukki.net
Changes in v6:
- rename driver to mvebu_mmc
- renames constants and functions
- move mmc_init to kirkwood/cpu
- code cleaning
<snip> > + > +#define mvebu_mmc_write(offs, val) writel(val, CONFIG_SYS_MMC_BASE + > (offs)) > +#define mvebu_mmc_read(offs) readl(CONFIG_SYS_MMC_BASE + (offs))
Wouldn't it be better to use functions instead of macros here?
or use structs?
Regards, Jeroen