
On 19 April 2017 at 08:46, Philipp Tomsich philipp.tomsich@theobroma-systems.com wrote:
This originally started out as "pinctrl: Kconfig: reorder to keep Rockchip options together" and tried to keep the Rockchip-related config options together.
However, we now rewrite all chip-specific driver selections to start with CONFIG_PINCTRL_ (with the inadvertent changes to related Makefiles) and sort those alphabetically. And as this already means touching most of the file, we also reformat the help text to not exceed 80 characters (but make full use of those 80 characters).
Signed-off-by: Philipp Tomsich philipp.tomsich@theobroma-systems.com
Changes in v3:
- sed lingering old options in defconfig to conform with the new naming scheme
- sed the ROCKCHIP_*_PINCTRL (which started this in the first place) into PINCTRL_ROCKCHIP_* for consistency with the new naming scheme
Changes in v2:
- sort options alphabetically and use a common naming (i.e. always start with CONFIG_PINCTRL_) for chip-specific drivers
configs/ap121_defconfig | 2 +- configs/chromebit_mickey_defconfig | 2 +- configs/chromebook_jerry_defconfig | 2 +- configs/chromebook_minnie_defconfig | 2 +- configs/evb-rk3036_defconfig | 2 +- configs/evb-rk3288_defconfig | 2 +- configs/evb-rk3328_defconfig | 2 +- configs/evb-rk3399_defconfig | 2 +- configs/fennec-rk3288_defconfig | 2 +- configs/firefly-rk3288_defconfig | 2 +- configs/kylin-rk3036_defconfig | 2 +- configs/miqi-rk3288_defconfig | 2 +- configs/popmetal-rk3288_defconfig | 2 +- configs/puma-rk3399_defconfig | 2 +- configs/rock2_defconfig | 2 +- configs/rock_defconfig | 2 +- configs/sandbox_defconfig | 4 +- configs/sandbox_noblk_defconfig | 4 +- configs/tinker-rk3288_defconfig | 2 +- drivers/pinctrl/Kconfig | 164 +++++++++++++++++++----------------- drivers/pinctrl/Makefile | 2 +- drivers/pinctrl/ath79/Makefile | 4 +- drivers/pinctrl/rockchip/Makefile | 10 +-- 23 files changed, 117 insertions(+), 105 deletions(-)
Acked-by: Simon Glass sjg@chromium.org