
The following series of patches prepares the ground to move the remaining board configuration entries out of the Makefile into the boards.cfg file, replacing multi-line scripts to fiddle with config.h and config.mk files into simple, single-line entries.
[PATCH 1/3] Build: Add "board options" column to boards.cfg
Build: Add "board options" column to boards.cfg
There are some boards where it's currently not possible to detect all board information at runtime, therefore a new column was added to boards.cfg .
This column can contain multiple options: a board configuration name, optionally followed by a colon (':') and a list of options, which are separated by comma (',').
In case of simple options like '256M_U_BOOT', these expand to "#define CONFIG_MK_256M_U_BOOT 1" in config.h . In case of assignments like 'RAM=8192', these expand to "#define CONFIG_MK_RAM 8192" in config.h .
Example:
FOO:HAS_BAR,BAZ=64
means: - the name of the board config file is include/configs/FOO.h - the generated file include/config.h will contain these lines:
#define CONFIG_HAS_BAR 1 #define CONFIG_BAZ 64
Signed-off-by: Marek Vasut marek.vasut@gmail.com
[wd@denx.de: edited commit message; added code to deal with an optional board configuration name]
Signed-off-by: Wolfgang Denk wd@denx.de
2 files changed, 31 insertions(+), 7 deletions(-)
[PATCH 2/3] mkconfig: change CONFIG_MK_ prefix into plain CONFIG_
mkconfig: change CONFIG_MK_ prefix into plain CONFIG_
When planning for more generalization and Makefile cleanup it became obvious that the introduction of a separate CONFIG_MK_ name space for config options that were set through scripting in the Makefile was not a good idea.
Originally the idea was to provide a script-free approach to supply configuration options - there was no real need for a separate name space. But when we now convert the existing Makefile entries to make use of this approach, it would mean that we have to touch a large number of board config files and add #ifdef / #define sequences to "convert" from the CONFIG_MK_ to the CONFIG_ name space.
It seems much cleaner to get rid of this somewhat arbitrary _MK string now for the few boards that actually use it.
Signed-off-by: Wolfgang Denk wd@denx.de
21 files changed, 54 insertions(+), 59 deletions(-)
[PATCH 3/3] Rename TEXT_BASE into CONFIG_SYS_TEXT_BASE
Rename TEXT_BASE into CONFIG_SYS_TEXT_BASE
The change is currently needed to be able to remove the board configuration scripting from the top level Makefile and replace it by a simple, table driven script.
Moving this configuration setting into the "CONFIG_*" name space is also desirable because it is needed if we ever should move forward to a Kconfig driven configuration system.
Signed-off-by: Wolfgang Denk wd@denx.de
799 files changed, 1494 insertions(+), 1436 deletions(-)
Potential testers can find these (and some more experimental) commits in the "Makefile-cleanup" branch in the u-boot-testing repository.
Best regards,
Wolfgang Denk