
Hi Alex,
On Tue, Jun 11, 2019 at 4:18 PM Alexandru Marginean alexandru.marginean@nxp.com wrote:
Hi Bin,
On 6/10/2019 6:42 AM, Bin Meng wrote:
Hi Alex,
On Sat, Jun 8, 2019 at 12:12 AM Alex Marginean alexm.osslist@gmail.com wrote:
Adds a driver for NXP ENETC ethernet controller currently integrated in LS1028a. ENETC is a fairly straight-forward BD ring device and interfaces are presented as PCI EPs on the SoC ECAM.
Signed-off-by: Catalin Horghidan catalin.horghidan@nxp.com Signed-off-by: Alex Marginean alexm.osslist@gmail.com
Changes in v2: - Added SXGMII MAC configuration - simplified naming code in _bind - renamed ENETC_DBG to enetc_dbg and make it use debug() - replaced a couple of magic numbers with macros - droped _V1 from PCI ID macro - several styling and cosmetic updates to the header file
configs/ls1028aqds_tfa_defconfig | 1 + configs/ls1028ardb_tfa_defconfig | 1 + drivers/net/Kconfig | 7 + drivers/net/Makefile | 1 + drivers/net/fsl_enetc.c | 344 +++++++++++++++++++++++++++++++ drivers/net/fsl_enetc.h | 172 ++++++++++++++++ include/pci_ids.h | 1 + 7 files changed, 527 insertions(+) create mode 100644 drivers/net/fsl_enetc.c create mode 100644 drivers/net/fsl_enetc.h
[snip]
diff --git a/include/pci_ids.h b/include/pci_ids.h index bd59578ccb..16cf0641c7 100644 --- a/include/pci_ids.h +++ b/include/pci_ids.h @@ -2483,6 +2483,7 @@ #define PCI_DEVICE_ID_MPC8641 0x7010 #define PCI_DEVICE_ID_MPC8641D 0x7011 #define PCI_DEVICE_ID_MPC8610 0x7018 +#define PCI_DEVICE_ID_ENETC_PF 0xE100
nits: suggest we put this macro to fsl_enetc.h, unless other codes besides the fsl_enetc driver want this macro? And only one ENETC id is listed here, how about other controllers (PFs)? Does the driver only support the PF0? If yes, name the macro to PCI_DEVICE_ID_ENETC_PF0.
Only enetc code uses it, I'm OK to move it. I just went with the flow, it looks like the PCI IDs are defined here.
There are 4 ENETC PFs on the SoC, and this ID applies to all of them. They are compatible between each other and probed by the same driver, so they don't need different IDs.
Thanks for the clarification about PF IDs. Then let's keep the original name PCI_DEVICE_ID_ENETC_PF.
#define PCI_VENDOR_ID_PASEMI 0x1959
Regards, Bin