
Hi,
On Mon, Dec 18, 2023 at 6:19 PM Raymond Mao raymond.mao@linaro.org wrote:
Major changes:
Update bloblist to align to Firmware Handoff spec v0.9 (up to commit #3592349 of the spec) (https://github.com/FirmwareHandoff/firmware_handoff).
Includes:
- Align bloblist tags with the FW handoff spec
- Add an explicit alignment field in the header
- Update bloblist magic and version
- Use a packed format for blob record header
- Change the checksum alorigthm
- Use a void entry to handle the alignment
- Adjust the headers of bloblist and blob record
- Align the bloblist record data section start address
In v3, the implementation from boot arguments to bloblist and how to load the FDT from the bloblist are moved to a forthcoming patch serie.
Raymond Mao (1): bloblist: Align bloblist used_size and total_size to spec
Simon Glass (13): bloblist: Update the tag numbering bloblist: Adjust API to align in powers of 2 bloblist: Change the magic value bloblist: Set version to 1 bloblist: Access record hdr_size and tag via a function bloblist: Drop spare value from bloblist record bloblist: Change the checksum algorithm bloblist: Checksum the entire bloblist bloblist: Handle alignment with a void entry bloblist: Reduce blob-header size bloblist: Adjust the bloblist header bloblist: Add alignment to bloblist_new() bloblist: Update documentation and header comment
arch/x86/lib/tables.c | 3 +- common/bloblist.c | 205 ++++++++++++++++++++++++--------------- doc/develop/bloblist.rst | 4 +- include/bloblist.h | 166 ++++++++++++++++++------------- test/bloblist.c | 105 +++++++++++--------- 5 files changed, 287 insertions(+), 196 deletions(-)
-- 2.25.1
Just to say that this series LGTM
Reviewed-by: Simon Glass sjg@chromium.org
Regards, Simonn