
Anton Vorontsov wrote:
In subsequent patches we'll use FSL-specific functions in fdt_fixup_dr_usb(), so let's move the routine to a more appropriate place.
So far fsl_dr_usb.c isn't actually an USB driver, but eventually it will turn into one, let's hope. ;-)
Also rename CONFIG_HAS_FSL_DR_USB to CONFIG_USB_FSL_DR to be consistent with other USB drivers.
Signed-off-by: Anton Vorontsov avorontsov@ru.mvista.com
board/freescale/mpc8315erdb/mpc8315erdb.c | 1 + board/freescale/mpc837xemds/mpc837xemds.c | 1 + board/freescale/mpc837xerdb/mpc837xerdb.c | 1 + common/fdt_support.c | 41 ---------------------- drivers/usb/Makefile | 1 + drivers/usb/fsl_dr_usb.c | 52 +++++++++++++++++++++++++++++ include/configs/MPC8315ERDB.h | 2 +- include/configs/MPC837XEMDS.h | 2 +- include/configs/MPC837XERDB.h | 2 +- include/fdt_support.h | 6 --- include/fsl_dr_usb.h | 21 +++++++++++ 11 files changed, 80 insertions(+), 50 deletions(-) create mode 100644 drivers/usb/fsl_dr_usb.c create mode 100644 include/fsl_dr_usb.h
Hi Anton,
I presume you CC:ed me on this series because fdt_support.c is involved. I view this as more of a board/processor issue than a libfdt issue: I'm happy to ack the concept, but leave it to Kim/Andy/Kumar to do the dirty work.
Thanks, gvb