
Hi Jagan,
On Tue, Sep 24, 2013 at 12:19 PM, Jagannadha Sutradharudu Teki jagannadha.sutradharudu-teki@xilinx.com wrote:
Added proper comment style on spi_flash structure to make more readable.
Signed-off-by: Jagannadha Sutradharudu Teki jaganna@xilinx.com
Changes for v4: - none Changes for v3: - none Changes for v2: - none
include/spi_flash.h | 63 +++++++++++++++++++++++++++++------------------------ 1 file changed, 35 insertions(+), 28 deletions(-)
diff --git a/include/spi_flash.h b/include/spi_flash.h index 14e4ae2..34a167b 100644 --- a/include/spi_flash.h +++ b/include/spi_flash.h @@ -37,39 +37,46 @@ # define CMD_SST_AAI_WP 0xAD /* Auto Address Incr Word Program */ #endif
+/**
- struct spi_flash - SPI flash structure
- @spi: SPI slave
- @name: Name of SPI flash
- @size: Total flash size
- @page_size: Write (page) size
- @sector_size: Sector size
- @erase_size: Erase size
- @bank_read_cmd: Bank read cmd
- @bank_write_cmd: Bank write cmd
- @bank_curr: Current flash bank
- @poll_cmd: Poll cmd - for flash erase/program
- @erase_cmd: Erase cmd 4K, 32K, 64K
- @memory_map: Address of read-only SPI flash access
- @read: Flash read ops
- @write: Flash write ops
- @erase: Flash erase ops
Should probably add full documentation for these functions (arguments and return value)
Regards, Simon