
7 Sep
2010
7 Sep
'10
7:37 p.m.
On Sun, 5 Sep 2010 14:37:13 -0700 Steve Sakoman sakoman@gmail.com wrote:
On Sun, Sep 5, 2010 at 3:59 AM, Sergei Shtylyov sshtylyov@mvista.com wrote:
On 02-09-2010 19:33, Steve Sakoman wrote:
diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c index ed1c9c9..b2400dd 100644 --- a/drivers/mtd/nand/nand_base.c +++ b/drivers/mtd/nand/nand_base.c @@ -2653,8 +2653,11 @@ static struct nand_flash_dev *nand_get_flash_type(struct mtd_info *mtd, }
if (!type) {
- printk(KERN_INFO "%s: unknown NAND device: Manufacturer ID:"
- " 0x%02x, Chip ID: 0x%02x\n", __func__,
- /* supress warning if there is no nand */
- if ((*maf_id != 0x00) && (*maf_id != 0xff) &&
- (dev_id != 0x00) && (dev_id != 0xff))
Parens around != are not necessary.
Understood -- I just think it is easier to read/understand with parens. If the general consensus is that I should remove them I am happy to do so.
My vote is no parens.
-Scott