
Scott Wood wrote:
On Fri, Aug 08, 2008 at 08:37:47AM -0500, Kumar Gala wrote:
Finally I'd like to change the subcommands to be prefixed with '_' to make parsing easier: bootm _start <args> bootm _prep bootm _load_os ...
Ick. How about using a different name than "bootm"?
-Scott
Yeah, reusing "bootm" may be too clever.
What I had in mind for overloading bootm is to do strncmp() operations for each of the subcommands (and where none of the subcommands could be interpreted as hex numbers - i.e. have a letter g-z or "_" in it) and, if none of the valid subcommands passed, do a legacy implementation where the three parameters are parsed as hex (or "-" for the ramdisk).
Again, while I like the concept of using "bootm" since we are familiar with it (and I don't have a better name), I would not be adverse to using a different command name since the New Improved "bootm" will be substantially different than bootm-classic.
Best regards, gvb