
On 4/8/22 16:30, Pali Rohár wrote:
DT node name should be generic, therefore rename atsha204a@64 to crypto@64.
Signed-off-by: Pali Rohár pali@kernel.org
Applied to u-boot-marvell/master
Thanks, Stefan
arch/arm/dts/armada-385-turris-omnia-u-boot.dtsi | 2 +- board/CZ.NIC/turris_atsha_otp.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/dts/armada-385-turris-omnia-u-boot.dtsi b/arch/arm/dts/armada-385-turris-omnia-u-boot.dtsi index 3ff76c946294..76a441524833 100644 --- a/arch/arm/dts/armada-385-turris-omnia-u-boot.dtsi +++ b/arch/arm/dts/armada-385-turris-omnia-u-boot.dtsi @@ -29,7 +29,7 @@ u-boot,dm-pre-reloc;
/* ATSHA204A at address 0x64 */
atsha204a@64 {
crypto@64 { u-boot,dm-pre-reloc; compatible = "atmel,atsha204a"; reg = <0x64>;
diff --git a/board/CZ.NIC/turris_atsha_otp.c b/board/CZ.NIC/turris_atsha_otp.c index 7a39b7f61d5d..8c39f5e52414 100644 --- a/board/CZ.NIC/turris_atsha_otp.c +++ b/board/CZ.NIC/turris_atsha_otp.c @@ -21,7 +21,7 @@ static struct udevice *get_atsha204a_dev(void) /* Cannot be static because BSS does not have to be ready at this early stage */ struct udevice *dev;
- if (uclass_get_device_by_name(UCLASS_MISC, "atsha204a@64", &dev)) {
- if (uclass_get_device_by_name(UCLASS_MISC, "crypto@64", &dev)) { puts("Cannot find ATSHA204A on I2C bus!\n"); dev = NULL; }
Viele Grüße, Stefan Roese