
-----Original Message----- From: Gerlando Falauto [mailto:gerlando.falauto@keymile.com] Sent: 25 July 2012 09:24 To: u-boot@lists.denx.de Cc: Gerlando Falauto; Holger Brunck; Prafulla Wadaskar; Valentin Longchamp Subject: [PATCH v4 3/4] kirkwood: implement kw_sdram_size_adjust
Size of the SDRAM chips might differ between any two (otherwise identical) instances of the same board.
So add a function kw_sdram_size_adjust() which reads out the current ram size for a given bank, and adjusts the Kirkwood's SDRAM window size register accordingly.
Signed-off-by: Gerlando Falauto gerlando.falauto@keymile.com Signed-off-by: Holger Brunck holger.brunck@keymile.com cc: Prafulla Wadaskar prafulla@marvell.com cc: Valentin Longchamp valentin.longchamp@keymile.com
changes for v4:
- add bank parameter to kw_sdram_size_adjust()
changes for v3:
- rename dram_size_fixup to kw_sdramsize_adjust and move them to
kirkwood/dram.c
changes for v2:
- rebase to current u-boot-marvell.git master branch
arch/arm/cpu/arm926ejs/kirkwood/dram.c | 11 +++++++++++ arch/arm/include/asm/arch-kirkwood/cpu.h | 1 + 2 files changed, 12 insertions(+), 0 deletions(-)
diff --git a/arch/arm/cpu/arm926ejs/kirkwood/dram.c b/arch/arm/cpu/arm926ejs/kirkwood/dram.c index 5e2f9d8..807894f 100644 --- a/arch/arm/cpu/arm926ejs/kirkwood/dram.c +++ b/arch/arm/cpu/arm926ejs/kirkwood/dram.c @@ -97,6 +97,17 @@ u32 kw_sdram_bs(enum memory_bank bank) return result; }
+void kw_sdram_size_adjust(enum memory_bank bank) +{
- u32 size;
- /* probe currently equipped RAM size */
- size = get_ram_size((void *)kw_sdram_bar(bank),
kw_sdram_bs(bank));
- /* adjust SDRAM window size accordingly */
- kw_sdram_bs_set(bank, size);
+}
#ifndef CONFIG_SYS_BOARD_DRAM_INIT int dram_init(void) { diff --git a/arch/arm/include/asm/arch-kirkwood/cpu.h b/arch/arm/include/asm/arch-kirkwood/cpu.h index d28c51a..23783d5 100644 --- a/arch/arm/include/asm/arch-kirkwood/cpu.h +++ b/arch/arm/include/asm/arch-kirkwood/cpu.h @@ -159,6 +159,7 @@ void reset_cpu(unsigned long ignored); unsigned char get_random_hex(void); unsigned int kw_sdram_bar(enum memory_bank bank); unsigned int kw_sdram_bs(enum memory_bank bank); +void kw_sdram_size_adjust(enum memory_bank bank); int kw_config_adr_windows(void); void kw_config_gpio(unsigned int gpp0_oe_val, unsigned int gpp1_oe_val, unsigned int gpp0_oe, unsigned int gpp1_oe); --
Applied to u-boot-marvell.git master branch
Regards... Prafulla . . .