
In message 20080111142800.8025.66590.stgit@hekate.izotz.org you wrote:
- Add inline helper macros for basic header processing
- Move common non inline code common/image.c
- Replace direct header access with the API routines
- Rename IH_CPU_* to IH_ARCH_*
Please review your patches and make sure to keep the original for- matting of the U-Boot output; for example:
--- a/common/cmd_bootm.c +++ b/common/cmd_bootm.c ... - if (crc32 (0, (uchar *)data, len) != ntohl(hdr->ih_dcrc)) { - puts (" Bad Data CRC\n"); - } - puts ("OK\n"); + if (!image_check_dcrc(hdr)) + puts ("Bad Data CRC\n");
This is IMO a change to the worse. Please fix.
--- a/include/image.h +++ b/include/image.h ... +char *strncpy(char *dest, const char *src, size_t count);
Please don't do this! Include the appropriate header file instead.
+static inline int image_check_target_arch(image_header_t *hdr)
Theoretical thought: could it ever happen that we might have a multi-architecture image?
Best regards,
Wolfgang Denk