
Dear dirk.behme@googlemail.com,
In message 49172e4a.0b38560a.42bc.ffffb794@mx.google.com you wrote:
Subject: [PATCH-OMAP3] OMAP3: Remove BITx magic
From: Dirk Behme dirk.behme@gmail.com
Remove bits.h and it's macros usage. Requested by Wolfgang Denk.
Signed-off-by: Dirk Behme dirk.behme@gmail.com
...
/* device type */ -#define DEVICE_MASK (BIT8 | BIT9 | BIT10) +#define DEVICE_MASK (0x7 << 8)
That's a funny way to make code difficult to read. Why do you prefer "(0x7 << 8)" instead of "0x700" (which looks more obvious to me) ?
-#define DLL_NO_FILTER_MASK (BIT8 | BIT9) +#define DLL_NO_FILTER_MASK ((0x1 << 9) | (0x1 << 8))
Ditto here - why not simply 0x300 ?
-#define GPT_EN ((0 << 2) | BIT1 | BIT0) +#define GPT_EN ((0x0 << 2) | (0x1 << 1) | (0x1 << 0))
Why not 0x3 ?
Note: especially the "(0x0 << 2) | " part in the expression i really bogus.
Best regards,
Wolfgang Denk