
Hi,
On 05/13/2015 09:26 PM, Ian Campbell wrote:
On Wed, 2015-05-13 at 17:09 +0200, Hans de Goede wrote:
diff --git a/board/sunxi/Kconfig b/board/sunxi/Kconfig index 940b6c7..d4ae6c7 100644 --- a/board/sunxi/Kconfig +++ b/board/sunxi/Kconfig @@ -95,6 +95,14 @@ config DRAM_ZQ ---help--- Set the dram zq value.
+if MACH_SUN8I_A33
Shouldn't this be a "depends on MACH_SUN8I_A33" in the entry itself? I see we use if a lot in this file, is there a reason for that or just how it has been done?
No special reason, just copy paste from elsewhere.
In any case using if here is at least consistent so no strong objection on that grounds.
+config DRAM_ODT_EN
- int "sunxi dram odt enable"
- default 0
- ---help---
- Set this to 1 to enable dram odt (on die termination)
Why is this an int rather than a bool?
Because it is used directly as an int in the code, otherwise I need to add #ifdef-ery. I guess I could make it a bool and use IS_ENABLED(), but that does lead to slightly less readable code IMHO.
Regards,
Hans