
18 Dec
2011
18 Dec
'11
8:20 p.m.
On Sunday 18 December 2011 13:56:12 Mike Frysinger wrote:
On Saturday 17 December 2011 12:03:13 Pali Rohár wrote:
--- /dev/null +++ b/common/cmd_clr.c
+int do_clr(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[])
static
- printf(ANSI_CLEAR_CONSOLE);
puts()
puts(s) will output s + '\n'. And we do not want newline after clear screen.
+U_BOOT_CMD(
- clr, CONFIG_SYS_MAXARGS, 1, do_clr,
- "clr",
- "\n"
- " - clear screen and move cursor to top of screen"
+);
"clr" is unusual. name it "clear" instead. that's what all the standard *nix systems use after all. -mike
ok, I will rename clr to clear.
--
Pali Rohár
pali.rohar@gmail.com