
21 Feb
2014
21 Feb
'14
4:07 p.m.
Hi!
- /*
* Check if the scan chain engine is inactive and the
* WFIFO is empty before enabling the IO scan chain
*/
- if (SCAN_MGR_IO_SCAN_ENGINE_STATUS_IDLE
!= scan_mgr_io_scan_chain_engine_is_idle(
MAX_WAITING_DELAY_IO_SCAN_ENGINE)) {
return 1;
- }
Hmm.. function named "_is_idle" maybe should just return 0 or 1?
/*
* Check if the scan chain engine has completed the
* IO scan chain data shifting
*/
if (SCAN_MGR_IO_SCAN_ENGINE_STATUS_IDLE
!= scan_mgr_io_scan_chain_engine_is_idle(
MAX_WAITING_DELAY_IO_SCAN_ENGINE)) {
/* Disable IO Scan chain when error detected */
clrbits_le32(&scan_manager_base->en,
1 << io_scan_chain_id);
return 1;
}
- }
"goto error" would help avoid code duplication.
+struct socfpga_scan_manager {
- u32 stat;
- u32 en;
- u32 padding[2];
- u32 fifosinglebyte;
- u32 fifodoublebyte;
- u32 fifoquadbyte;
+};
some underscores should be added here.
Thanks, Pavel
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html