
On Wed, 10 Jun 2009 00:23:28 +0400 Anton Vorontsov avorontsov@ru.mvista.com wrote:
On Fri, May 01, 2009 at 12:31:54AM +0200, Wolfgang Denk wrote:
Dear Anton,
In message 20090429215000.GA1092@oksana.dev.rtsoft.ru you wrote:
This patch implements simple hwconfig infrastructure: an interface for software knobs to control a hardware.
Thanks a lot.
We support hwconfig options with arguments. For example,
set hwconfig dr_usb,dr_usb_mode:peripheral,dr_usb_phy_type:ulpi
There are three hwconfig options selected:
- dr_usb - enable Dual-Role USB controller;
- dr_usb_mode:peripheral - USB in Function mode;
- dr_usb_phy_type:ulpi - USB should work with ULPI PHYs.
That gives a lot of typing, which in turn results in lots of typing errors, which in this case are probably nasty to debug.
Suggestion: instead of
set hwconfig dr_usb,dr_usb_mode:peripheral,dr_usb_phy_type:ulpi
use:
set hwconfig dr_usb:mode=peripheral,phy_type=ulpi
What do you think?
Sorry for the delay. Done. New patches on the way.
I had made a similar comment to the original hwconfig posting that appears to have been missed:
http://lists.denx.de/pipermail/u-boot/2009-April/051845.html
the existing syntax is flawed, e.g., what is the separator character going to be when you want to configure something more than dr_usb using the syntax used in this patchseries? And can we adopt a syntax that's more familiar (or recognizable) to our users from the outset?
Kim