
Hi Wolfgang,
There was a fair amount of grey area as far as environment variable naming for those variables that used to refernce autoscr.
Why actually?
I guess because we don't see eye-to-eye:)
Indeed. We really should have a U-Boot developers meeting ...
I'm always up for U-Boot and beer;)
<snip>
autoscript - if set to "yes" commands like "loadb", "loady", "bootp", "tftpb", "rarpboot" and "nfs" will attempt to automatically run script images (by internally calling "source").
This should be killed in this process, as it does nothing but duplicate the function of the "autostart" variable, just for another image type. It does not make sense to invent new names for the same function for all current and furture image types.
I can generate a patch that replaces the functionality of the "autoscript" environment variable with "autostart", but we'd still have to take care of the "autoscript_uname" variable:
autoscript_uname - if script image is in a format (FIT) this variable is used to get script subimage unit name.
So I'd vote to either: 1. Remove support for the "autoscript" and "autoscript_uname" variables altogether now. There's been a warning in feature-removal-schedule.txt, I can't imagine that many people use them, and it seems like a waste of effort to migrate "autoscript/autoscript_uname" to "autostart" if its a feature that we're going to remove anyway.
2. Add a deprecated warning message when the autoscript* variables are used and then remove them 2 releases from now.
<snip>
Would you prefer to keep the functionality of the "autoscript" variable but with a different name, or remove that functionality altogether? Or are you referring to the references of "autoscript" in the board/matrix_vision/mvbc_p/mvbc_p_autoscript and board/matrix_vision/mvblm7/mvblm7_autoscript files?
We should merge this into "autostart".
How do we deal with "autoscript_uname"? I'd vote for #1 above and remove them both. People can work around the change in functionality by explicitly calling "source" after they download a script image.
A little off topic, but I'd personally love to get rid of the autoscript/autoscript_uname/autostart/autoload variables and have people explicitly use the commands they need. For example, the dhcp command would only set some environment variable values, then tftp/nfs would have to be called, followed by the appropriate boot command. Right now, the dhcp command behave in a number of different ways depending on the values of the auto* variables mentioned above. Same with tftp, loadb, etc.
I see, and I tend to agree. But then, we should also rename the commands, i. e. "dhcpboot" -> "dhcp", "tftpboot" -> "tftp", etc. Maybe this should be done in a two-step procedure, too: first introduce the new commands (which already changes default behaviour if you just type for example "tftp"), then deprecate and (after a sufficient transition period) remove the old commands.
Sounds good, I'll send some patches to do this and see what people think.
Best, Peter