
The README file states that the macros beginning with "CONFIG_SYS_" depend on the hardware etc. and should not be meddled with if you do not what you're doing. We have already screwed up with this policy; we have given the prefix "CONFIG_SYS_" to many user-selectable configurations. Here, "CONFIG_SYS_HUSH_PARSER" is one of them. Users can enable it if they want to use a more powerful command line parser, or disable it if they only need a simple one.
This commit attempts to rename CONFIG_SYS_HUSH_PARSER to CONFIG_HUSH_PARSER and move it to Kconfig.
Every board maintainer is expected to enable CONFIG_HUSH_PARSER (= add "CONFIG_HUSH_PARSER=y" to his defconfig file) and remove "#define CONFIG_SYS_HUSH_PARSER" from his header file.
Signed-off-by: Masahiro Yamada yamada.m@jp.panasonic.com ---
README | 12 ------------ common/Kconfig | 17 +++++++++++++++++ 2 files changed, 17 insertions(+), 12 deletions(-)
diff --git a/README b/README index c3a9dfc..66ec1cb 100644 --- a/README +++ b/README @@ -2834,18 +2834,6 @@ CBFS (Coreboot Filesystem) support
Enable auto completion of commands using TAB.
- CONFIG_SYS_HUSH_PARSER - - Define this variable to enable the "hush" shell (from - Busybox) as command line interpreter, thus enabling - powerful command line syntax like - if...then...else...fi conditionals or `&&' and '||' - constructs ("shell scripts"). - - If undefined, you get the old, much simpler behaviour - with a somewhat smaller memory footprint. - - CONFIG_SYS_PROMPT_HUSH_PS2
This defines the secondary prompt string, which is diff --git a/common/Kconfig b/common/Kconfig index 216a8de..7f8359d 100644 --- a/common/Kconfig +++ b/common/Kconfig @@ -1,6 +1,23 @@ menu "Command line interface" depends on !SPL_BUILD
+config HUSH_PARSER + bool "Use hush shell" + select SYS_HUSH_PARSER + help + This option enables the "hush" shell (from Busybox) as command line + interpreter, thus enabling powerful command line syntax like + if...then...else...fi conditionals or `&&' and '||' + constructs ("shell scripts"). + + If disabled, you get the old, much simpler behaviour with a somewhat + smaller memory footprint. + +config SYS_HUSH_PARSER + bool + help + Backward compatibility. + config CMD_BOOTM bool "Enable bootm command" default y