
On 10/17/24 9:50 AM, Paul Geurts wrote:
The imx_sec_config_fuse_t structure is not specific to the sec_config fuse, but can be used for all fuse words.
Rename the structure to a more generic name to be reused for other fuses.
Signed-off-by: Paul Geurts paul.geurts@prodrive-technologies.com
arch/arm/include/asm/mach-imx/hab.h | 4 ++-- arch/arm/mach-imx/hab.c | 4 ++-- arch/arm/mach-imx/imx8m/soc.c | 2 +- arch/arm/mach-imx/mx6/soc.c | 2 +- arch/arm/mach-imx/mx7/soc.c | 2 +- arch/arm/mach-imx/mx7ulp/soc.c | 2 +- 6 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/arch/arm/include/asm/mach-imx/hab.h b/arch/arm/include/asm/mach-imx/hab.h index 2abf28ea45bc..52cd8aff87e1 100644 --- a/arch/arm/include/asm/mach-imx/hab.h +++ b/arch/arm/include/asm/mach-imx/hab.h @@ -132,13 +132,13 @@ enum hab_target { HAB_TGT_ANY = 0x55, };
-struct imx_sec_config_fuse_t { +struct imx_fuse_t {
Please drop the _t suffix from it, otherwise it resembles all those downstream typedef struct {} stuff_t; constructs.
Thanks !