
On Fri, Oct 01, 2021 at 04:37:40PM +0900, Masahisa Kojima wrote:
On Tue, 28 Sept 2021 at 05:21, Ilias Apalodimas ilias.apalodimas@linaro.org wrote:
On Tue, Sep 21, 2021 at 04:19:30PM +0900, Masahisa Kojima wrote:
This commit adds the UEFI GPT disk partition topology measurement required in TCG PC Client PFP Spec.
Signed-off-by: Masahisa Kojima masahisa.kojima@linaro.org
(no changes since v1)
include/blk.h | 3 + include/efi_loader.h | 2 +- include/efi_tcg2.h | 12 +++ lib/efi_loader/efi_boottime.c | 2 +- lib/efi_loader/efi_tcg2.c | 175 +++++++++++++++++++++++++++++++++- 5 files changed, 191 insertions(+), 3 deletions(-)
diff --git a/include/blk.h b/include/blk.h index 19bab081c2..f0cc7ca1a2 100644 --- a/include/blk.h +++ b/include/blk.h @@ -45,6 +45,9 @@ enum if_type { #define BLK_PRD_SIZE 20 #define BLK_REV_SIZE 8
+#define PART_FORMAT_PCAT 0x1
This isn't used anywhere
UEFI spec says:
Partition Format: 0x01 – PC-AT compatible legacy MBR 0x02 – GUID Partition Table
I think it is better to define both value even if one of them is not used.
Fair enough
@@ -230,6 +230,18 @@ struct smbios_handoff_table_pointers2 { struct efi_configuration_table table_entry[]; } __packed;
+/**
- struct tdUEFI_GPT_DATA - event log structure of industry standard tables
- @uefi_partition_header: gpt partition header
- @number_of_partitions: the number of partition
- @partitions: partition entries
- */
+struct efi_gpt_data {
gpt_header uefi_partition_header;
u64 number_of_partitions;
gpt_entry partitions[];
+} __packed;
struct efi_tcg2_protocol { efi_status_t (EFIAPI * get_capability)(struct efi_tcg2_protocol *this, struct efi_tcg2_boot_service_capability *capability); diff --git a/lib/efi_loader/efi_boottime.c b/lib/efi_loader/efi_boottime.c index 701e2212c8..bf5661e1ee 100644 --- a/lib/efi_loader/efi_boottime.c +++ b/lib/efi_loader/efi_boottime.c @@ -3003,7 +3003,7 @@ efi_status_t EFIAPI efi_start_image(efi_handle_t image_handle,
if (IS_ENABLED(CONFIG_EFI_TCG2_PROTOCOL)) { if (image_obj->image_type == IMAGE_SUBSYSTEM_EFI_APPLICATION) {
ret = efi_tcg2_measure_efi_app_invocation();
ret = efi_tcg2_measure_efi_app_invocation(image_obj); if (ret != EFI_SUCCESS) { log_warning("tcg2 measurement fails(0x%lx)\n", ret);
diff --git a/lib/efi_loader/efi_tcg2.c b/lib/efi_loader/efi_tcg2.c index 4f68f6dfd5..ea2c1ead03 100644 --- a/lib/efi_loader/efi_tcg2.c +++ b/lib/efi_loader/efi_tcg2.c @@ -1525,12 +1525,181 @@ static void *find_smbios_table(void) return NULL; }
+/**
- search_gpt_dp_node() - search gpt device path node
- @device_path: device path
- Return: pointer to the gpt device path node
- */
+static struct +efi_device_path *search_gpt_dp_node(struct efi_device_path *device_path) +{
struct efi_device_path *dp = device_path;
while (dp) {
if (dp->type == DEVICE_PATH_TYPE_MEDIA_DEVICE &&
dp->sub_type == DEVICE_PATH_SUB_TYPE_HARD_DRIVE_PATH) {
struct efi_device_path_hard_drive_path *hd_dp =
(struct efi_device_path_hard_drive_path *)dp;
if (hd_dp->partmap_type == PART_FORMAT_GPT &&
On dp_part_node() partmap_type is set to 2 for EFI partition types. Why do we interpret it as 'GPT' here?
UEFI spec says: partmap_type = 0x02 – GUID Partition Table
Ah yes my bad, it's setting that to '2' indeed based on the 'struct blk_desc' info. This is correct
total_gpt_entry_size = gpt_h->num_partition_entries *
[...]
gpt_h->sizeof_partition_entry;
orig_gpt_e = calloc(1, total_gpt_entry_size + block_io->media->io_align);
entry = (void *)ALIGN((uintptr_t)orig_gpt_e, block_io->media->io_align);
if (!entry) {
ret = EFI_OUT_OF_RESOURCES;
goto out2;
}
ret = block_io->read_blocks(block_io, block_io->media->media_id,
gpt_h->partition_entry_lba,
total_gpt_entry_size, entry);
if (ret != EFI_SUCCESS)
goto out2;
Can't you use efi_bl_read() here, instead of searching for the protocol? If you can, moving that out of a static function would make more sense.
With chat discussion with Ilias, we concluded not to do this modification.
Indeed efi_bl_read() cant be used here. Just a heads up to the rest of the people in this thread, just replace the alignment calls with PTR_ALIGN() and split the allocation/reading to a different fucntion. This should make this code a lot more readable.
Thanks! /Ilias
Thanks, Masahisa Kojima
/* count valid GPT entry */
gpt_e = entry;
for (i = 0; i < gpt_h->num_partition_entries; i++) {
if (guidcmp(&null_guid, &gpt_e->partition_type_guid))
num_of_valid_entry++;
gpt_e = (gpt_entry *)((u8 *)gpt_e + gpt_h->sizeof_partition_entry);
}
/* prepare event data for measurement */
event_size = sizeof(struct efi_gpt_data) +
(num_of_valid_entry * gpt_h->sizeof_partition_entry);
event = calloc(1, event_size);
if (!event) {
ret = EFI_OUT_OF_RESOURCES;
goto out2;
}
memcpy(event, gpt_h, sizeof(gpt_header));
put_unaligned_le64(num_of_valid_entry, &event->number_of_partitions);
/* copy valid GPT entry */
gpt_e = entry;
num_of_valid_entry = 0;
for (i = 0; i < gpt_h->num_partition_entries; i++) {
if (guidcmp(&null_guid, &gpt_e->partition_type_guid)) {
memcpy((u8 *)event->partitions +
(num_of_valid_entry * gpt_h->sizeof_partition_entry),
gpt_e, gpt_h->sizeof_partition_entry);
num_of_valid_entry++;
}
gpt_e = (gpt_entry *)((u8 *)gpt_e + gpt_h->sizeof_partition_entry);
}
ret = tcg2_measure_event(dev, 5, EV_EFI_GPT_EVENT, event_size, (u8 *)event);
if (ret != EFI_SUCCESS)
goto out2;
+out2:
EFI_CALL(efi_close_protocol((efi_handle_t)block_io, &efi_block_io_guid,
NULL, NULL));
free(orig_gpt_h);
free(orig_gpt_e);
free(event);
+out1:
efi_free_pool(device_path);
return ret;
+}
/**
- efi_tcg2_measure_efi_app_invocation() - measure efi app invocation
- Return: status code
*/ -efi_status_t efi_tcg2_measure_efi_app_invocation(void) +efi_status_t efi_tcg2_measure_efi_app_invocation(struct efi_loaded_image_obj *handle) { efi_status_t ret; u32 pcr_index; @@ -1569,6 +1738,10 @@ efi_status_t efi_tcg2_measure_efi_app_invocation(void) goto out; }
ret = tcg2_measure_gpt_data(dev, handle);
if (ret != EFI_SUCCESS)
goto out;
tcg2_efi_app_invoked = true;
out: return ret; -- 2.17.1
Cheers /Ilias