
Hi Eric,
On 26/08/2013 16:23, Eric Nelson wrote:
Functionally, we still need table(s) for any image which supports either variant so the proper set of pads are configured.
See this for an example http://lists.denx.de/pipermail/u-boot/2012-October/136394.html
Ok - what I meant is to avoid to convert the static definitions (enums) in the header in a sort of tables. I agree that using tables in the board code is needed and makes the code more readable using imx_iomux_v3_setup_multiple_pads().
The construct used in that patch set was to define FOR_DL_SOLO, then include the pad file. #ifdef CONFIG_MX6Q #include "pads.h" #endif #if defined(CONFIG_MX6DL) || defined(CONFIG_MX6S) #define FOR_DL_SOLO #include "pads.h" #endif
Troy's implementation used a naming convention of mx6q_X and mx6dl_solo_X such that a board supporting both would have variables
static iomux_v3_cfg_t mx6q_usdhc3_pads = ...
followed by
static iomux_v3_cfg_t mx6dl_solo_usdhc3_pads = ...
ok, this is a solution. Let's wait for next Tapani's patch and when we start the discussion ;-)
Best regards, Stefano