
Move this option to Kconfig, renaming it into CONFIG_CACHE_UNIPHIER. The new option name makes sense enough, and the same as Linux has.
Signed-off-by: Masahiro Yamada yamada.masahiro@socionext.com ---
arch/arm/mach-uniphier/Kconfig | 7 +++++++ arch/arm/mach-uniphier/arm32/cache-uniphier.c | 2 +- include/configs/uniphier.h | 3 --- 3 files changed, 8 insertions(+), 4 deletions(-)
diff --git a/arch/arm/mach-uniphier/Kconfig b/arch/arm/mach-uniphier/Kconfig index e39ced6..a558073 100644 --- a/arch/arm/mach-uniphier/Kconfig +++ b/arch/arm/mach-uniphier/Kconfig @@ -70,6 +70,13 @@ config ARCH_UNIPHIER_LD6B depends on ARCH_UNIPHIER_PRO5_PXS2_LD6B default y
+config CACHE_UNIPHIER + bool "Enable the UniPhier L2 cache controller" + depends on ARCH_UNIPHIER_32BIT + default y + help + This option allows to use the UniPhier System Cache as L2 cache. + config MICRO_SUPPORT_CARD bool "Use Micro Support Card" help diff --git a/arch/arm/mach-uniphier/arm32/cache-uniphier.c b/arch/arm/mach-uniphier/arm32/cache-uniphier.c index 77a0b78..da9488e 100644 --- a/arch/arm/mach-uniphier/arm32/cache-uniphier.c +++ b/arch/arm/mach-uniphier/arm32/cache-uniphier.c @@ -206,7 +206,7 @@ void uniphier_cache_disable(void) uniphier_cache_endisable(0); }
-#ifdef CONFIG_UNIPHIER_L2CACHE_ON +#ifdef CONFIG_CACHE_UNIPHIER void v7_outer_cache_flush_all(void) { uniphier_cache_maint_all(UNIPHIER_SSCOQM_CM_FLUSH); diff --git a/include/configs/uniphier.h b/include/configs/uniphier.h index e485583..2606e53 100644 --- a/include/configs/uniphier.h +++ b/include/configs/uniphier.h @@ -27,9 +27,6 @@
#define CONFIG_SYS_CACHELINE_SIZE 32
-/* Comment out the following to disable L2 cache */ -#define CONFIG_UNIPHIER_L2CACHE_ON - #define CONFIG_DISPLAY_CPUINFO #define CONFIG_DISPLAY_BOARDINFO #define CONFIG_MISC_INIT_F