
On Thu, 11 Jun 2009 18:39:43 +0400 Anton Vorontsov avorontsov@ru.mvista.com wrote:
On Thu, Jun 11, 2009 at 09:09:56AM -0500, Kim Phillips wrote: [...]
Suggestion: instead of
set hwconfig dr_usb,dr_usb_mode:peripheral,dr_usb_phy_type:ulpi
use:
set hwconfig dr_usb:mode=peripheral,phy_type=ulpi
What do you think?
Sorry for the delay. Done. New patches on the way.
I had made a similar comment to the original hwconfig posting that appears to have been missed:
http://lists.denx.de/pipermail/u-boot/2009-April/051845.html
I didn't miss it. ;-)
this repost didn't make that instantly clear enough to me ;-)
the existing syntax is flawed, e.g., what is the separator character going to be when you want to configure something more than dr_usb using the syntax used in this patchseries?
The separator between options is ';', between sub-options is ','.
So that would be 'dr_usb:mode=host,phy_type=ulpi; esdhc".
Which translates to
dr_usb { mode = host; phy_type = ulpi; };
esdhc;
And can we adopt a syntax that's more familiar (or recognizable) to our users from the outset?
Sure, I'm open to suggestions. Originally you proposed this scheme:
set hwconfig "usb=dr; dr_usb_mode=peripheral; dr_usb_phy_type=ulpi"
But Wolfgang proposed options and sub-options to save some typing (notice the repetitive dr_usb), so there should be two assignment symbols and two symbols for separation.
if you don't want to type, things like this are possible but they have to depend on the order given:
dr_usb.mode = host; .phy_type = ulpi; esdhc;
however when automating/scripting concatenation of them, it's useful to not have to depend on their order:
dr_usb.mode = host; esdhc; dr_usb.phy_type = ulpi;
...so as you can see I've come up with the dot ('.') in order to eliminate the less familiar (and therefore more misleading) colon (':').
What do you think?
Kim
p.s., your representation above is the best, but now it's starting to look like the frontend to a C compiler:
"dr_usb { mode = host; phy_type = ulpi; }; esdhc;"