
Hi Nikita,
On 15 December 2014 at 05:02, Nikita Kiryanov nikita@compulab.co.il wrote:
Gentle ping.
On 12/08/2014 05:14 PM, Nikita Kiryanov wrote:
This series is a first step towards an end goal of merging all CONFIG_LCD related functionality into CONFIG_VIDEO code. My plan is to start by refactoring lcd.c into something cleaner (less ifdefs) and more modular (split code into multiple files), then possibly refactor CONFIG_VIDEO code if needed, and then finally: move CONFIG_LCD related functionality over to CONFIG_VIDEO code, replacing as much CONFIG_LCD related code with CONFIG_VIDEO related code as possible.
This specific step eliminates some unused code and refactors lcd console stuff into its own file.
The patches ("lcd: rename console_(row|col)" to "lcd: make lcd_drawchars() independant of lcd_base") are preparatory patches meant to illustrate exactly what changed and where in the transition from lcd.c to lcd_console.c, and are not necesserily code improvements when viewed out of context.
Changes in V3: - Function documentation - Cache values of lcd_get(bg|fg)color() instead of calling the functions multiple times.
The whole series was rebased over current mainline, and compile tested for arm and powerpc.
Cc: Anatolij Gustschin agust@denx.de Cc: Wolfgang Denk wd@denx.de Cc: Simon Glass sjg@chromium.org Cc: Stephen Warren swarren@wwwdotorg.org
Entire series: Tested-by: Stephen Warren swarren@wwwdotorg.org Tested-by: Simon Glass sjg@chromium.org
Nikita Kiryanov (12): lcd: remove CONFIG_SYS_INVERT_COLORS lcd: cleanup lcd_drawchars mpc8xx_lcd: get rid of CONFIG_EDT32F10 lcd: remove LCD_MONOCHROME lcd: rename console_(row|col) lcd: replace CONSOLE_(ROWS|COLS) with variables lcd: expand console api lcd: get rid of COLOR_MASK lcd: introduce getters for bg/fg color lcd: make lcd_drawchars() independant of lcd_base lcd: refactor lcd console stuff into its own file lcd_console: remove unused defines
common/Makefile | 2 +- common/lcd.c | 313 +++++---------------------------------------- common/lcd_console.c | 211 ++++++++++++++++++++++++++++++ drivers/video/mpc8xx_lcd.c | 49 +------ drivers/video/pxa_lcd.c | 15 --- include/configs/R360MPI.h | 1 - include/lcd.h | 25 ++-- include/lcd_console.h | 86 +++++++++++++ 8 files changed, 347 insertions(+), 355 deletions(-) create mode 100644 common/lcd_console.c create mode 100644 include/lcd_console.h
I think Anatolij will be applying this. Does it go into this release?
Regards, Simon