
So I proposed a set of subcommands that looked like:
bootm start <args> bootm prep bootm load_os bootm load_fdt bootm load_initrd bootm jump bootm restore
is this the right granularity or should we go finer?
"prep" could be:
bootm disable_interrupts bootm usb_stop bootm disable_caches
"load_os" stays as is.
"load_fdt" could be:
bootm load_fdt bootm boardsetup_fdt bootm fdt_resize
"load_initrd" could be: bootm load_initrd bootm fdt_initrd_fixup
"jump" stays as is.
"restore" could be: bootm enable_interrupts bootm usb_start bootm enable_caches
Also I'm adding in: bootm cmdline bootm kbd (kernel bd_t)
Finally I'd like to change the subcommands to be prefixed with '_' to make parsing easier: bootm _start <args> bootm _prep bootm _load_os ...
- k