
On 9/18/20 6:03 PM, Biju Das wrote:
[...]
+++ b/board/hoperun/hihope-rzg2/hihope-rzg2.c @@ -0,0 +1,80 @@
[...]
+#define RST_BASE 0xE6160000 +#define RST_CA57RESCNT (RST_BASE + 0x40) +#define RST_CODE 0xA5A5000F
+/* If the firmware passed a device tree use it for U-Boot DRAM setup. */ +extern u64 rcar_atf_boot_args[];
+DECLARE_GLOBAL_DATA_PTR;
+void s_init(void) +{ +}
Is this empty function needed ?
+#ifdef CONFIG_BOARD_EARLY_INIT_F +/* Kconfig forces this on, so just return 0 */
I think BOARD_EARLY_INIT_F should really be disabled in Kconfig rather than implementing empty function here.
+int board_early_init_f(void) +{
- return 0;
+} +#endif
[...]
+int fdtdec_board_setup(const void *fdt_blob) +{
- void *atf_fdt_blob = (void *)(rcar_atf_boot_args[1]);
- if (fdt_magic(atf_fdt_blob) == FDT_MAGIC)
fdt_overlay_apply_node((void *)fdt_blob, 0, atf_fdt_blob, 0);
- return 0;
+}
Please use board/renesas/rcar-common/common.c , no need to duplicate the code.
+int dram_init(void) +{
- return fdtdec_setup_mem_size_base();
+}
+int dram_init_banksize(void) +{
- return fdtdec_setup_memory_banksize();
+}
+void reset_cpu(ulong addr) +{
- writel(RST_CODE, RST_CA57RESCNT);
+}
Isn't there CA53 core in the RZG2 too ?
[...]