
Dear Jean-Christophe PLAGNIOL-VILLARD,
In message 1242468896-5007-1-git-send-email-plagnioj@jcrosoft.com you wrote:
actually the console API use the following naming convention
======Extract====== typedef struct device_t;
int device_register (device_t * dev); int devices_init (void); int device_deregister(char *devname); struct list_head* device_get_list(void); device_t* device_get_by_name(char* name); device_t* device_clone(device_t *dev); =======
which is device generic and confusing
instead of using device_XX and device_t we now switch to stdio_XX and stdio_dev
this will also allow to add later a generic device mecanism in order to have multi generic device support and driver instance
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagnioj@jcrosoft.com
board/MAI/AmigaOneG3SE/ps2kbd.c | 6 +- board/MAI/AmigaOneG3SE/video.c | 6 +- board/ads5121/ads5121_diu.c | 2 +- board/bf527-ezkit/video.c | 6 +- board/bf533-stamp/video.c | 6 +- board/bf548-ezkit/video.c | 6 +- board/bmw/bmw.c | 2 +- board/freescale/mpc8610hpcd/mpc8610hpcd_diu.c | 2 +- board/linkstation/avr.c | 2 +- board/mpl/common/common_util.c | 2 +- board/mpl/common/isa.c | 2 +- board/mpl/common/kbd.c | 6 +- board/mpl/pati/pati.c | 6 +- board/netphone/phone_console.c | 6 +- board/rbc823/kbd.c | 8 ++-- board/trab/vfd.c | 2 +- common/Makefile | 2 +- common/cmd_console.c | 8 ++-- common/cmd_log.c | 6 +- common/cmd_terminal.c | 6 +- common/console.c | 36 +++++++++--------- common/iomux.c | 14 +++--- common/lcd.c | 6 +- common/serial.c | 8 ++-- common/{devices.c => stdio.c} | 50 ++++++++++++------------ common/usb_kbd.c | 14 +++--- cpu/blackfin/jtag-console.c | 6 +- cpu/mpc8xx/lcd.c | 2 +- cpu/mpc8xx/video.c | 6 +- cpu/pxa/pxafb.c | 2 +- drivers/input/keyboard.c | 6 +- drivers/net/netconsole.c | 6 +- drivers/serial/arm_dcc.c | 6 +- drivers/serial/usbtty.c | 6 +- drivers/usb/musb/musb_hcd.c | 4 +- drivers/usb/musb/musb_hcd.h | 2 +- drivers/video/cfb_console.c | 6 +- include/configs/AmigaOneG3SE.h | 2 +- include/configs/MIP405.h | 2 +- include/configs/MPC8610HPCD.h | 2 +- include/configs/MPC8641HPCN.h | 2 +- include/configs/PIP405.h | 2 +- include/configs/VCMA9.h | 2 +- include/configs/gr_ep2s60.h | 2 +- include/configs/mp2usb.h | 2 +- include/console.h | 36 ------------------ include/iomux.h | 6 +- include/serial.h | 2 +- include/{devices.h => stdio_dev.h} | 32 ++++++++-------- lib_arm/board.c | 4 +- lib_avr32/board.c | 4 +- lib_blackfin/board.c | 6 +- lib_blackfin/post.c | 2 +- lib_i386/board.c | 4 +- lib_i386/video.c | 10 ++-- lib_m68k/board.c | 6 +- lib_mips/board.c | 6 +- lib_nios/board.c | 4 +- lib_nios2/board.c | 4 +- lib_ppc/board.c | 6 +- lib_sh/board.c | 4 +- lib_sparc/board.c | 6 +- post/post.c | 2 +- 63 files changed, 198 insertions(+), 234 deletions(-) rename common/{devices.c => stdio.c} (84%) delete mode 100644 include/console.h rename include/{devices.h => stdio_dev.h} (85%)
Applied - after editing the commit message; hope this is OK. Thanks.
Best regards,
Wolfgang Denk