
Dear Stefan Roese,
In message 1277796281-19728-1-git-send-email-sr@denx.de you wrote:
This patch adds support for the T3CORP board, based on the AppliedMicro (AMCC) PPC460GT.
General question: should we rename "amcc" into "apm" ?
...
+int board_early_init_r(void) +{
...
- /* Add TLB entry for 0xfn00.0000 -> 0x4.cn00.0000 */
- program_tlb(CONFIG_SYS_FLASH_BASE_PHYS, CONFIG_SYS_FLASH_BASE,
CONFIG_SYS_FLASH_SIZE, TLB_WORD2_I_ENABLE);
- /*
* Now accessing of the whole 64Mbytes of NOR FLASH at virtual address
* 0xfc00.0000 is possible
*/
What about the configuration with 128 MiB NOR flash? Would it not be more flexible to use something like
program_tlb(CONFIG_SYS_FLASH_END_PHYS-flash_info[0].size, -flash_info[0].size, flash_info[0].size, TLB_WORD2_I_ENABLE);
with CONFIG_SYS_FLASH_END_PHYS_H = 0x4 and CONFIG_SYS_FLASH_END_PHYS_L = 0xD0000000
?
BTW: Please use "flash" (globally) instead of FLASH - "flash" is not an abbreviation.
+int board_pcie_last(void) +{
- /*
* Only PCIe0 for now, PCIe1 hangs on this boards
"on this board" or "on these boards"
Best regards,
Wolfgang Denk