
Mike Frysinger wrote:
On Sunday, July 25, 2010 20:07:31 Reinhard Meyer wrote:
I can rename the current driver to like "enc28j60_lpc2292.c" and make the two affected boards use it, so they still compile and work. I can't do those boards' maintainers work and add the required code to use the new driver and make a generic spi framework for the lpc2292. They currently use a very private spi approach. Or I call the new driver something like "enc28j60_generic.c". I am definitely not going to port the existing two lpc2292 boards to use the new enc28j60 driver.
i prefer the former
I agree. So a first patch would be the renaming, editing the affected boards *.h and the Makefile in drivers/net: COBJS-$(CONFIG_ENC28J60) += enc28j60.o to COBJS-$(CONFIG_ENC28J60_LPC2292) += enc28j60_lpc2292.o
In the same patch extract the 200 or so defines for the chip to enc28j60.h (to be used by both drivers).
One issue remains: the old driver has a lot of coding style violations, I can fix them, but see no point in that. The new driver will have them fixed.
But before I proceed I need Bens OK to go that way:)
Reinhard