
18 Aug
2015
18 Aug
'15
4 a.m.
On 17 August 2015 at 04:45, Bin Meng bmeng.cn@gmail.com wrote:
This commit cleans up the existing i8042 driver by:
- Reorder those static function so that their declarations can be removed
- Remove unused routines i8042_flush() and i8042_disable()
- Remove unused CONFIG_USE_CPCIDVI wrapped codes
- Remove __weak board_i8042_skip()
- Rename CamelCase variables to conform U-Boot coding convention
- Rename wait_until_kbd_output_full() to kbd_output_full()
- Change to use macros for i8042 command and control register bits
Signed-off-by: Bin Meng bmeng.cn@gmail.com
drivers/input/i8042.c | 633 +++++++++++++++++++++----------------------------- include/i8042.h | 112 +++++---- 2 files changed, 317 insertions(+), 428 deletions(-)
It would be better to split this into a few patches (e.g. one to remove stuff, one to reorder, one for everything else) but this is a big improvement.
Acked-by: Simon Glass sjg@chromium.org