
This test doesn't belong at the top level. Move it into the common/ directory, to match its implementation. Rename it to drop the unnecessary _ut suffix.
Signed-off-by: Simon Glass sjg@chromium.org ---
test/Makefile | 1 - test/common/Makefile | 1 + test/{print_ut.c => common/print.c} | 0 3 files changed, 1 insertion(+), 1 deletion(-) rename test/{print_ut.c => common/print.c} (100%)
diff --git a/test/Makefile b/test/Makefile index 4366e495a15..9f19bfa472b 100644 --- a/test/Makefile +++ b/test/Makefile @@ -14,7 +14,6 @@ endif ifneq ($(CONFIG_HUSH_PARSER),) obj-$(CONFIG_$(XPL_)CMDLINE) += hush/ endif -obj-$(CONFIG_$(XPL_)CMDLINE) += print_ut.o obj-$(CONFIG_$(XPL_)CMDLINE) += str_ut.o obj-$(CONFIG_UT_TIME) += time_ut.o obj-y += ut.o diff --git a/test/common/Makefile b/test/common/Makefile index b6bff9201ec..53c4f16164d 100644 --- a/test/common/Makefile +++ b/test/common/Makefile @@ -7,3 +7,4 @@ endif obj-$(CONFIG_CYCLIC) += cyclic.o obj-$(CONFIG_EVENT_DYNAMIC) += event.o obj-y += cread.o +obj-$(CONFIG_$(XPL_)CMDLINE) += print.o diff --git a/test/print_ut.c b/test/common/print.c similarity index 100% rename from test/print_ut.c rename to test/common/print.c