
On Wed, Aug 20, 2014 at 12:32:45PM -0600, Stephen Warren wrote:
On 08/18/2014 01:16 AM, Thierry Reding wrote:
[...]
diff --git a/arch/arm/cpu/tegra124-common/xusb-padctl.c b/arch/arm/cpu/tegra124-common/xusb-padctl.c
+int fdtdec_count_strings(const void *fdt, int node, const char *prop_name)
+int fdtdec_get_string_index(const void *fdt, int node, const char *prop_name,
int index, const char **output)
+int fdtdec_get_string(const void *fdt, int node, const char *prop_name,
Shouldn't those be in libfdt or similar? I thought I saw a patch to do that.
I renamed the current fdt_get_string_index() to fdt_find_string() in the hope of removing the naming ambiguity and added these two as fdt_get_string_index() and fdt_get_string(). And I moved the fdtdec_count_strings() into libfdt as well and named it fdt_count_strings().
Thierry