
Hi Marek,
-----Original Message----- From: Marek Vasut [mailto:marex@denx.de] Sent: Sunday, January 24, 2016 3:38 AM To: Anand Moon Cc: Joe Hershberger; Ted; Stephen Warren; Joe Hershberger; u-boot Subject: Re: [U-Boot] [PATCH v5 2/2] usb: eth: add Realtek RTL8152B/RTL8153 DRIVER
On Saturday, January 23, 2016 at 07:55:58 PM, Anand Moon wrote:
Hi Marek,
On 23 January 2016 at 20:53, Marek Vasut marex@denx.de wrote:
On Saturday, January 23, 2016 at 01:42:55 AM, Marek Vasut wrote:
On Friday, January 22, 2016 at 09:41:33 PM, Joe
Hershberger wrote:
Hi Marek,
On Fri, Jan 22, 2016 at 2:00 PM, Marek Vasut
marex@denx.de wrote:
On Friday, January 22, 2016 at 08:50:04 PM, Joe
Hershberger wrote:
> On Wed, Jan 20, 2016 at 12:24 AM, Ted Chen > tedchen@realtek.com
wrote:
> > This patch adds driver support for the Realtek > > RTL8152B/RTL8153 USB network adapters. > > > > Signed-off-by: Ted Chen <tedchen at realtek.com>
[swarren,
> > fixed a few compiler warnings] [swarren, with permission, > > converted license header to SPDX] [swarren,
removed printf()
> > spew during probe()] > > Signed-off-by: Stephen Warren <swarren at nvidia.com> > > --- > > > > drivers/usb/eth/Makefile | 1 + > > drivers/usb/eth/r8152.c | 1456 > > +++++++++++++++++++++++++++++++++++++++++++ > > drivers/usb/eth/r8152.h > > > > | 631 +++++++++++++++++++ > > > > drivers/usb/eth/r8152_fw.c | 980
+++++++++++++++++++++++++++++
> > drivers/usb/eth/usb_ether.c | 7 + > > include/usb_ether.h | 6 + > > 6 files changed, 3081 insertions(+) create mode 100644 > > drivers/usb/eth/r8152.c create mode 100644 > > drivers/usb/eth/r8152.h create mode 100644 > > drivers/usb/eth/r8152_fw.c > > > > Changes for v2: Modified by Marek's comments. > > - Remove pattern informations. > > - Don't allocate & free when read/write register. > > - relpace udelay to mdelay. > > - pull firmware into global variable. > > - code review. > > > > Changes for v3: Modified by Marek's and Joe's comments. > > - Remove driver version informations. > > - separate firmware code to individual file. > > - split extensive defines to r8152.h. > > - code review. > > > > Changes for v4: Modified by Marek's comments. > > - remove the redundant code in generic_ocp_read and > > generic_ocp_write. - remove redundant typecasting. > > - collect the codes of busy waiting to
rtl8152_reinit_ll and
> > rtl8152_nic_reset. - use ARRAY_SIZE() to avoid
having 0x00
> > as a terminating entry of r8152_dongles. - using if > > (!ep_in_found && (ep_addr & USB_DIR_IN)) ... to
replace old
> > version. - code review. > > > > Changes for v5: Modified by Marek's comments. > > - add r8152_wait_for_bit to replace busy wait. > > - change the name of patch4 to r8152b_set_dq_desc. > > - add r8152_versions to store the hw's version. > > Acked-by: Joe Hershberger joe.hershberger@ni.com
Do you want to pick this or shall I ?
If there is some dependency (patch 1) that you will
take first,
you can just take this as well.
I cannot find patch 1/2.
Ted, can you repost both of the patches , so I can pick them ?
I applied 2/2 to u-boot-usb since it seems harmless, but I still don't know what 1/2 is .
Best regards,
I probably belive this is the patch.
Thanks, in that case , please repost that one patch.
The patch 1/2 is there : https://patchwork.ozlabs.org/patch/544360/
That patch is posted by "Stephen Warren".
Thanks~
BRs Ted