
On Thu, Sep 13, 2012 at 08:20:16AM +0200, Lukasz Majewski wrote:
Hi Tom,
Thanks for review.
On 09/12/2012 07:50 AM, Lukasz Majewski wrote:
This patch series provides a new command - "gpt" for eMMC partition table (in the GPT format) restoration.
As a pre-work, some cleanup at the part_efi.c file was performed to remove custom macros and make GPT related structures more readable.
Moreover the part_efi.h file has been moved to ./include directory to be easily available from other subsystems.
The GPT detailed description has been written to README.gpt file.
Tested at: - Exynos4210 rev.1 - TRATS Samsung development board
I had two very minor comments. Aside from that, please make sure the series is checkpatch clean (I haven't checked). Thanks!
There is one little problem with the checkpatch:
The patch: [PATCH v2 2/7] part:efi: Move part_efi.h file to ./include
"touches" some legacy code, and checkpatch complaints about e.g.:
WARNING: do not add new typedefs #281: FILE: include/part_efi.h:97: +typedef struct _gpt_header {
which I don't want to change in this patch series.
Moreover it complaints about: WARNING: __packed is preferred over __attribute__((packed)) #303: FILE: include/part_efi.h:119: +} __attribute__ ((packed)) gpt_entry_attributes; which was changed at further patch (which I believe is a better place to do so): [PATCH v2 4/7] gpt: The leXX_to_int() calls replaced with ones defined at <compiler.h>
To sum up - some checkpatch warnings appears since I've moved a legacy code to a new place. Rest of those patches is checkpatch "clean".
Sounds good to me, thanks for the explanation.