
On 1/8/19 2:06 PM, Jean-Jacques Hiblot wrote:
On 08/01/2019 13:47, Marek Vasut wrote:
On 1/8/19 1:43 PM, Jean-Jacques Hiblot wrote:
On 08/01/2019 12:18, Marek Vasut wrote:
On 1/8/19 11:40 AM, Jean-Jacques Hiblot wrote:
This series applies on top of u-boot-dfu.
This series renames CONFIG_SPL_USB_GADGET_SUPPORT to CONFIG_SPL_USB_GADGET for consistency. It also uses CONFIG_USB_GADGET to compile-in the gadget code. This make sure that the code is not included if it is not needed. Some defconfigs had to be updated as they relied on the gadget code to be always compiled.
TRAVIS: https://travis-ci.org/jjhiblot/u-boot/builds/476452900
Jean-Jacques Hiblot (2): Kconfig: rename CONFIG_SPL_USB_GADGET_SUPPORT as CONFIG_SPL_USB_GADGET usb: Make compiling gadget support optional
Makefile | 4 ++-- arch/arm/mach-imx/mx6/Kconfig | 2 +- arch/arm/mach-imx/spl.c | 2 +- common/spl/Kconfig | 4 ++-- configs/am335x_boneblack_vboot_defconfig | 2 +- configs/am335x_evm_usbspl_defconfig | 2 +- configs/am43xx_evm_defconfig | 2 +- configs/am43xx_hs_evm_defconfig | 2 +- configs/apalis_imx6_defconfig | 2 +- configs/cm_t3517_defconfig | 1 + configs/cm_t35_defconfig | 1 + configs/colibri_imx6_defconfig | 2 +- configs/display5_factory_defconfig | 2 +- configs/duovero_defconfig | 1 + configs/igep0032_defconfig | 1 + configs/igep00x0_defconfig | 1 + configs/imx6q_logic_defconfig | 2 +- configs/mx6memcal_defconfig | 2 +- configs/mx6sabresd_defconfig | 2 +- configs/omap3_zoom1_defconfig | 1 + configs/omap4_panda_defconfig | 1 + configs/omap4_sdp4430_defconfig | 1 + configs/pico-hobbit-imx6ul_defconfig | 2 +- configs/pico-hobbit-imx7d_defconfig | 2 +- configs/pico-imx6ul_defconfig | 2 +- configs/pico-imx7d_defconfig | 2 +- configs/pico-pi-imx6ul_defconfig | 2 +- configs/pico-pi-imx7d_defconfig | 2 +- configs/spear300_usbtty_defconfig | 2 ++ configs/spear300_usbtty_nand_defconfig | 2 ++ configs/spear310_usbtty_defconfig | 2 ++ configs/spear310_usbtty_nand_defconfig | 2 ++ configs/spear310_usbtty_pnor_defconfig | 2 ++ configs/spear320_usbtty_defconfig | 2 ++ configs/spear320_usbtty_nand_defconfig | 2 ++ configs/spear320_usbtty_pnor_defconfig | 2 ++ configs/spear600_usbtty_defconfig | 2 ++ configs/spear600_usbtty_nand_defconfig | 2 ++ drivers/Makefile | 6 +++--- drivers/usb/gadget/Makefile | 2 +- scripts/Makefile.spl | 2 +- 41 files changed, 55 insertions(+), 27 deletions(-)
I'll let Lukasz handle integrating this. Does it get rid of the patch I complained about in the PR ? I hope so ..
I applies on top of u-boot-dfu and fixes the issue you complained about.
It doesn't get rid of the patch per se but rather is a complement.
Can they be squashed together somehow ?
IMO they make more sense as separate patches. but I see no problem if Lukasz wants to squash them.
I'd prefer to replace the broken patch.