
Hi Bin,
On Mon, 29 Jun 2020 at 20:33, Bin Meng bmeng.cn@gmail.com wrote:
Hi Simon,
On Mon, Jun 15, 2020 at 11:57 AM Simon Glass sjg@chromium.org wrote:
At present we can only read from a top-level binman node entry. Refactor this function to produce a second local function which supports reading from any node.
Signed-off-by: Simon Glass sjg@chromium.org
lib/binman.c | 18 ++++++++++++------ 1 file changed, 12 insertions(+), 6 deletions(-)
diff --git a/lib/binman.c b/lib/binman.c index dc3a880882..79d01230dd 100644 --- a/lib/binman.c +++ b/lib/binman.c @@ -29,25 +29,31 @@ struct binman_info {
static struct binman_info *binman;
-int binman_entry_find(const char *name, struct binman_entry *entry) +int binman_entry_find_(ofnode node, const char *name, struct binman_entry *entry)
This one should be static. We really should agree on a naming convention for such internal APIs. I would prefer adding _internal suffix, or using __ prefix
Well I think internal is too long and I like a trailing underscore.
The trailing double underscore is reserved for the compiler.
Another option is to drop the prefix, so:
find_entry(...)
Regards, Simon