
Hi Fabio,
On 11.04.2013 17:48, Fabio Estevam wrote:
+u32 get_board_rev(void) +{
return get_cpu_rev();
+}
You can drop this, since I recently sent a patch that places it on a common location.
Hmmm, removing this function results in this error:
$ ./MAKEALL titanium Configuring for titanium - Board: titanium, Options: IMX_CONFIG=board/freescale/titanium/imximage.cfg make: *** [u-boot] Error 139 arm-linux-gnueabi-size: ./u-boot: File format not recognized arch/arm/lib/libarm.o: In function `setup_revision_tag': /home/stefan/git/u-boot/u-boot/arch/arm/lib/bootm.c:215: undefined reference to `get_board_rev' ...
So your patch is not in mainline yet? Is it in the ARM custodian repo? Then the pending ARM PR will solve this.
+/* Physical Memory Map */ +#define CONFIG_NR_DRAM_BANKS 1 +#define PHYS_SDRAM MMDC0_ARB_BASE_ADDR +#define PHYS_SDRAM_SIZE (1u * 512 * 1024 * 1024)
When I initially submitted the Wandboard support patch, Wolfgang commented that this '1u' is not really needed, and then I used SZ_512M, which provides better readability. Maybe you can do the same here?
I have no strong feelings here, but with Wolfgang preference of the "<<" notation, I'll change to this:
#define PHYS_SDRAM_SIZE (512 << 20)
I find this also quite easy to read: "x << 10" is "x KiB" and "y << 20" is "y MiB". Nothing obscured via some defines.
Best regards, Stefan