
10 Mar
2014
10 Mar
'14
6:24 p.m.
On 03/05/2014 09:45 AM, Przemyslaw Marczak wrote:
Changes: Move functions:
- disk/part_efi.c uuid_string() to lib/uuid.c -> uuid_bin_to_str()
- disk/part_efi.c string_uuid() to lib/uuid.c -> uuid_str_to_bin()
Update files:
- include/common.h
- disk/part_efi.c
- lib/Makefile
That's not a particularly useful patch description. How about:
Move uuid<->string conversion functions into lib/uuid.c so they can be used by code outside part_efi.c. Rename uuid_string() to uuid_bin_to_str(), so that's the naming is consistent with the existing uuid_str_to_bin(). Add an error return code to uuid_str_to_bin(). Convert existing users to the new library functions.
This one patch, Acked-by: Stephen Warren swarren@nvidia.com
diff --git a/lib/Makefile b/lib/Makefile
obj-$(CONFIG_BOOTP_PXE) += uuid.o +obj-$(CONFIG_PARTITION_UUIDS) += uuid.o
Oh, I hope listing uuid.o twice in obj-y won't cause any issue...