
commit ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to PHY_INTERFACE_MODE_NA") broke the phy_string_for_interface function. Fix it.
Fixes ffb0f6f488b9 ("treewide: Rename PHY_INTERFACE_MODE_NONE to PHY_INTERFACE_MODE_NA") Signed-off-by: Tim Harvey tharvey@gateworks.com Cc: Marek BehĂșn marek.behun@nic.cz Cc: Stefan Roese sr@denx.de Cc: Ramon Fried rfried.dev@gmail.com Cc: Vladimir Oltean vladimir.oltean@nxp.com --- include/phy_interface.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/phy_interface.h b/include/phy_interface.h index ce3b5004ec22..fed3357b9a26 100644 --- a/include/phy_interface.h +++ b/include/phy_interface.h @@ -85,7 +85,7 @@ static const char * const backplane_mode_strings[] = { static inline const char *phy_string_for_interface(phy_interface_t i) { /* Default to unknown */ - if (i > PHY_INTERFACE_MODE_NA) + if (i >= PHY_INTERFACE_MODE_MAX) i = PHY_INTERFACE_MODE_NA;
return phy_interface_strings[i];