
-----Original Message----- From: Wolfgang Denk [mailto:wd@denx.de] Sent: Thursday, October 21, 2010 12:08 PM To: u-boot@lists.denx.de Cc: Wolfgang Denk; Prafulla Wadaskar; Siddarth Gore; Simon Kagstrom; Heiko Schocher; Eric Cooper Subject: [RFC] [PATCH] kirkwood: get rid of config.mk files
After moving the definition of CONFIG_SYS_TEXT_BASE to the respective board config files, all Marvell kirkwood board have just a single and common entry in their config.mk files:
KWD_CONFIG = $(SRCTREE)/board/$(BOARDDIR)/kwbimage.cfg
Replace the only reference to KWD_CONFIG in the top level Makefile by an equivalent setting, and remove all kirkwood config.mk files.
Signed-off-by: Wolfgang Denk wd@denx.de Cc: Prafulla Wadaskar prafulla@marvell.com Cc: Siddarth Gore gores@marvell.com Cc: Simon Kagstrom simon.kagstrom@netinsight.net Cc: Heiko Schocher hs@denx.de Cc: Eric Cooper ecc@cmu.edu
Hi,
this is a (basicly untested) proposal how to clean up support for the kirkwood boards. Unfortunately I have no hardware available to test any of this, so I need your help here.
Thanks.
Wolfgang Denk
Makefile | 4 ++- board/Marvell/guruplug/config.mk | 27
board/Marvell/mv88f6281gtw_ge/config.mk | 28
board/Marvell/openrd_base/config.mk | 33
board/Marvell/rd6281a/config.mk | 28
board/Marvell/sheevaplug/config.mk | 28
board/keymile/km_arm/config.mk | 28
include/configs/guruplug.h | 2 + include/configs/km_arm.h | 2 + include/configs/mv88f6281gtw_ge.h | 2 + include/configs/openrd_base.h | 2 + include/configs/rd6281a.h | 2 + include/configs/sheevaplug.h | 2 + 13 files changed, 15 insertions(+), 173 deletions(-) delete mode 100644 board/Marvell/guruplug/config.mk delete mode 100644 board/Marvell/mv88f6281gtw_ge/config.mk delete mode 100644 board/Marvell/openrd_base/config.mk delete mode 100644 board/Marvell/rd6281a/config.mk delete mode 100644 board/Marvell/sheevaplug/config.mk delete mode 100644 board/keymile/km_arm/config.mk
diff --git a/Makefile b/Makefile index 06c71a2..2ec1172 100644 --- a/Makefile +++ b/Makefile @@ -357,7 +357,9 @@ $(obj)u-boot.imx: $(obj)u-boot.bin -e $(CONFIG_SYS_TEXT_BASE) -d $< $@
$(obj)u-boot.kwb: $(obj)u-boot.bin
$(obj)tools/mkimage -n $(KWD_CONFIG) -T kwbimage \
$(obj)tools/mkimage \
-n $(SRCTREE)/board/$(CONFIG_BOARDDIR)/kwbimage.cfg \
Hi Wolfgang This will not address other forecasted use cases like- 1. if the new board is added to boards/ (i.e. no BOARDDIR) 2. it will force each board to have it's own kwbimage.cfg even though two boards need same configuration, i.e. code duplication.
In my opinion, we can keep this default setup with CONFIG_SYS_KWD_CONFIG support in addition.
Regards.. Prafulla . .