
On Wed, May 18, 2016 at 5:39 PM, Miao Yan yanmiaobest@gmail.com wrote:
This patch splits qfw command interface and qfw core function into two files, and introduces a new Kconfig option (CONFIG_QFW). for
nits: . should be removed
I can fix when applying
qfw core.
Now when qfw command interface is enabled, it will automatically select qfw core. This patch also makes the ACPI table generation select CONFIG_QFW.
Signed-off-by: Miao Yan yanmiaobest@gmail.com
Changes in v2:
- do not use #ifdef...#end when including header files
- cleanup blank line at the end of file
- rename cmd_qfw.c to qfw.c
arch/x86/Kconfig | 2 +- arch/x86/cpu/mp_init.c | 4 +- arch/x86/cpu/qemu/Makefile | 3 +- arch/x86/cpu/qemu/qemu.c | 2 + cmd/Kconfig | 1 + cmd/Makefile | 2 +- cmd/{qemu_fw_cfg.c => qfw.c} | 172 ---------------------------------------- drivers/misc/Kconfig | 6 ++ drivers/misc/Makefile | 1 + drivers/misc/qemu_fw_cfg.c | 184 +++++++++++++++++++++++++++++++++++++++++++ 10 files changed, 200 insertions(+), 177 deletions(-) rename cmd/{qemu_fw_cfg.c => qfw.c} (55%) create mode 100644 drivers/misc/qemu_fw_cfg.c
Reviewed-by: Bin Meng bmeng.cn@gmail.com