
Dear Gary Jennejohn,
In message 20081030142153.1761d6fa@ernst.jennejohn.org you wrote:
Is it correct to assume that this patch version does not yet include any changes resultiung from the discussion we had yesterday how to optimize timing behaviour?
Yes. It also doesn't appear to me that this has been resolved yet.
Well, you're in a position to try it out. I ain't.
As this is a user configurable option, it should be named CONFIG_CONSOLE_MUX. Please remove the "SYS_" part. And please keep the list sorted.
I chose this analogously to CONFIG_SYS_CONSOLE_IS_IN_ENV. Obviously I misunderstand something about how these names are chosen. Please enlighten me.
CONFIG_SYS_CONSOLE_IS_IN_ENV was incorrectly chosen. It should be CONFIG_CONSOLE_IS_IN_ENV as well.
Sounds good to me. I wasn't aware of CONFIG_WD_MAX_RATE. There are way too many undocumented options in u-boot.
Please feel free to send patches to improve the documentation.
- int i;
- device_t *dev;
- for (i = 0; i < cd_count[console]; i++) {
dev = console_devices[console][i];
serial_printf("%s ", dev->name);
- }
- serial_printf("\n");
+}
The old code uses plain printf(), while your new version explicitely calls serial_printf(). I gues sthis is intentional? What is the rationale behind it?
To avoid writing to e.g. nc before it's ready for output.
I'm not sure if this is a good idea. It changes existing behaviour, and thisis always a bad thing. Assume systems with LCD display, where output usually goes there. I think it should be up to the nc driver to handle tyhis and, for example, ignore such calls until it has been sufficiently initialized.
Thanks.
Best regards,
Wolfgang Denk