
We use the U_BOOT_ prefix (i.e. U_BOOT_DRIVER) to declare a driver but in every other case we just use DM_. Update the alias macros to use the DM_ prefix.
We could perhaps rename U_BOOT_DRIVER() to DM_DRIVER(), but this macro is widely used and there is at least some benefit to indicating it us a U-Boot driver, particularly for code ported from Linux. So for now, let's keep that name.
Signed-off-by: Simon Glass sjg@chromium.org ---
doc/driver-model/of-plat.rst | 6 +++--- drivers/gpio/mxc_gpio.c | 2 +- drivers/gpio/mxs_gpio.c | 2 +- drivers/gpio/sandbox.c | 2 +- drivers/i2c/rk_i2c.c | 2 +- drivers/mmc/fsl_esdhc_imx.c | 2 +- drivers/mmc/mxsmmc.c | 2 +- drivers/mmc/rockchip_dw_mmc.c | 4 ++-- drivers/mtd/spi/sf_probe.c | 2 +- drivers/pinctrl/nxp/pinctrl-imx6.c | 2 +- drivers/pinctrl/nxp/pinctrl-mxs.c | 2 +- drivers/pinctrl/pinctrl-at91.c | 2 +- drivers/power/pmic/rk8xx.c | 2 +- drivers/serial/ns16550.c | 6 +++--- drivers/spi/mxs_spi.c | 2 +- drivers/spi/rk_spi.c | 2 +- include/dm/device.h | 2 +- tools/dtoc/dtb_platdata.py | 6 +++--- tools/dtoc/dtoc_test_scan_drivers.cxx | 2 +- 19 files changed, 26 insertions(+), 26 deletions(-)
Applied to u-boot-dm/next, thanks!