
Hi Philippe,
Thanks for the work.
Philippe Reynes philippe.reynes@softathome.com wrote on Fri, 16 Nov 2018 14:56:57 +0100:
This serie is a RFC to port the support of driver brcmnand from kernel 4.18 to u-boot. I've tried to stay as close as possible to the kernel. In this first port, I haven't ported the support of DMA, it's not mandatory in the first step and it could be added later.
This code has been tested on bcm6838 (mips) and bcm6858 (arm64). This code isn't clean enough to be integrated. I just send this serie to show the code and ask some question.
In the code, I've used "#ifndef __UBOOT__" to show the difference between the kernel code. Is it a good way or is it better to just replace the code ?
I think it is a good way. I find harder to read the code, but much easier to apply patches from Linux.
I've also added a file with brcmnand_compat.[hc] to compat function with the kernel (for example platform_get_resource_byname). What is the prefered way to support this function on u-boot ?
- just replace them by other code on u-boot
- just add this function on the brcmnand driver
- share this code for others driver (adding compat file for platform device, ...)
In your case, helpers might find their ways in their respective original .c/.h files. But then you can modify them to fit with U-Boot (why not with a #ifdef __UBOOT__?). Plus, I think you missed some of them that are already existing in U-Boot (even if they are dummy inline functions for instance).
Boris Brezillon (1): mtd: nand: provide several helpers to do common NAND operations
Brian Norris (1): mtd: add get/set of_node/flash_node helpers
Marc Gonzalez (1): mtd: nand: import nand_hw_control_init()
When you pick commits from other authors, what you do is:
[Linux commit: d45bc58dd3bdcaabc1d7d8d9b0b8dee826635cc6] [Philippe Reynes: adapt code to u-boot and only keep new function] Signed-off-by: Philippe Reynes philippe.reynes@softathome.com
Signed-off-by: Philippe Reynes philippe.reynes@softathome.com ---
* I think the [Linux commit:] is generally in the commit log itself, before the Git tags. * You don't need this extra SoB tag at the end. * I suggest that you always keep the entire file, even when adding unused functions, so that they will be available later if we continue backporting; so there will not be two commits with the exact same title+author in the future. If it triggers build issues, just add #ifdef statements.
Also, all patches must come with a description in the commit log (but this is a preliminary version so you probably just did not take the time).
Thanks, Miquèl