
Dear Kim Phillips,
In message 20091029182304.469c9f7f.kim.phillips@freescale.com you wrote:
if (field < PIN_MUX_NUM_FIELDS &&
(value & ~PIN_MUX_FIELD_MASK) == 0) {
the second line should not be indented as though it is the code subblock; it should fall directly underneath the column where 'field <..' starts, like this:
Agreed.
if (field < PIN_MUX_NUM_FIELDS && (value & ~PIN_MUX_FIELD_MASK) == 0) {
int offset = field * PIN_MUX_FIELD_SIZE;
unsigned int mux = pins[i].mux;
unsigned int mask = PIN_MUX_FIELD_MASK << offset;
also please just declare everything at the top of the function - same for value and field declarations above.
No! Why should that be needed? It would be just a waste of stack space (except that recent compilers don't care abouyt this anyway), and keeping variables as localized as possible seems to be a good thing to me.
value <<= offset;
writel(value | (readl(mux) & (~mask)), mux);
I guess arm doesn't have setbits32 and friends, huh.
Not yet. Patches welcome!
Best regards,
Wolfgang Denk