
Hi Miao,
On Mon, May 16, 2016 at 5:50 PM, Miao Yan yanmiaobest@gmail.com wrote:
Hi Bin,
2016-05-16 16:47 GMT+08:00 Bin Meng bmeng.cn@gmail.com:
Hi Miao,
On Fri, May 13, 2016 at 2:29 PM, Miao Yan yanmiaobest@gmail.com wrote:
This patch splits qfw command interface and qfw core function into two files, and introduces a new Kconfig option (CONFIG_QFW). for qfw core.
Now when qfw command interface is enabled, it will automatically select qfw core. This patch also makes the ACPI table generation select CONFIG_QFW.
Signed-off-by: Miao Yan yanmiaobest@gmail.com
arch/x86/Kconfig | 2 +- arch/x86/cpu/mp_init.c | 6 +- arch/x86/cpu/qemu/Makefile | 3 +- arch/x86/cpu/qemu/acpi_table.c | 2 + arch/x86/cpu/qemu/qemu.c | 4 + cmd/Kconfig | 1 + cmd/Makefile | 2 +- cmd/cmd_qfw.c | 182 +++++++++++++++++++++
The file name should be qfw.c without cmd_
cmd/qemu_fw_cfg.c | 353 -----------------------------------------
And I suspect you can also use "git mv" for cmd/qemu_fw_cfg.c. "git mv cmd/qemu_fw_cfg.c cmd/qfw.c"
But there is already a qfw.c under driver/misc/, having two files using the same name seems a bit confusing.
No problem because they are in different directory, and the command one is in a directory named 'cmd'.
Regards, Bin